Sign in to follow this  
Followers 0
godking

Help with BtS

25 posts in this topic

OK, been a long time since I played Civ 4 BTS. Last time was just before 5 came out.

 

After I got disillusioned with 5, I decided to go back to BtS, but discovered that it was corrupted. Only new software in that time was Civ 5, so I just assuemed that somehow there was a compatibilty issue or something and forgot all about it. Today I tried to run it again, found the same problem, so I did an uninstall of BtS and reinstall. However, this didn't fix it.

 

When I try to start BtS (or any Civ 4 - vanilla, warlords, etc) all I get are XML Load Error messages. After clicking on them for 30 or so error messages, I usually give up on clicking the "OK's" and just open the program manager and close down Civ 4.

 

I was going to uninstall all of 4 and restart, but I just cannot find all of the old disks. Only disks I have that I can find are BtS and Warlords. Heck, I don't even remember if BtS was the 2nd or 3rd expansion for 4, so I am not sure of just how many disks I am even missing.

 

So, anybody have any ideas on how to solve this - other than re-purchasing it off steam? To be honest, I don't want to give Firaxis any more money considering what they did to 5, though I will likely get the new X-Com in a last hope that the company will put out quality products.

Share this post


Link to post

Grrr, and now 5 wont start either.....

Share this post


Link to post

You only need the disks for Vanilla and BtS. Shouldn't have any need for the Warlords disk...

 

some of the XML files are still in the Vanilla folders, so your likely getting errors from those. Try to see if vanilla will work first and make sure it's fully patched (the patches are here on WPC somewhere).

Share this post


Link to post

Problem is I cannot find the vanilla disks. When I try to start vanilla, first thing I get is a message saying "please insert the correct disk" due too their silly copy protection BS.

 

So, doing some online stuff, I have a few things I can try, but failing that I will just have to repurchase it as a complete civ 4 pack from steam - and I am not willing to do that. Particularly when I cannot get Civ 5 to even work or figure out how to uninstall and reinstall 5.... having a real bad weekend, and this is just a little bit of frosting on top of the whole pastry.

Share this post


Link to post

Well, relax, have a beer (I am right now) and we'll see about what we can do to help you. I could send you mine, but I would have to dig it out of my storage unit...

Share this post


Link to post

Yeah - sounds like a re-install of all of Civ IV. As E_T said - you will need the original Civ IV disc and the BtS - no need for Warlords.

 

It does seem weird that Civ 5 has stopped working as well.

 

or figure out how to uninstall and reinstall 5

 

Depends on how you first got the game. If you purchased it directly off Steam, then it should just be a matter of right clicking on it in your Steam Library and selecting "Remove all local content" (or words to that effect. Once that is done it will appear slightly greyed out - click on it to download it again.

 

If you got a physical disc - then use the above method to remove it from your Steam library then inset the disc and re-install.

Share this post


Link to post

make sure that when you reinstall, thatt you install the Vanilla first, then patch it (download on this site), then install the BtS and patch it (again, from this site). Then, if you want, you can then install any additional Mods.

Share this post


Link to post
make sure that when you reinstall, thatt you install the Vanilla first, then patch it (download on this site), then install the BtS and patch it (again, from this site). Then, if you want, you can then install any additional Mods.

 

Actually E_T, I think the recommended method is to:

 

1. install vanilla

2. install bts

3. patch to 3.19

 

Am I correct here gang?

Share this post


Link to post

does the BtS install bring vanilla up to it's full patch?? so my way has one more step, but it's a safer method, too...

Share this post


Link to post

Yes it does.

 

Why is it safer? One more step is one more chance to trip. :cute:

Share this post


Link to post

I think Beta is right. This is what I am doing myself at least. I dont play vanilla though.

Share this post


Link to post
Actually E_T, I think the recommended method is to:

 

1. install vanilla

2. install bts

3. patch to 3.19

 

Am I correct here gang?

 

Yep.

 

No harm in patching vanilla first, but it's not necessary.

Share this post


Link to post

Hmmm, looked around some more when I got home, and still cannot find it. Might buy a $4 disc off eBay or Amazon if I cannot find it in the next couple of days.

Share this post


Link to post

This is the error message I keep getting with Civ 5. Going to do an uninstall and reinstall on it tonight (I think).

 

I got DX9 to load up ok, but it was acting kinda odd...

 

 

Problem signature:

Problem Event Name: BEX

Application Name: CivilizationV_DX11.exe

Application Version: 1.0.1.511

Application Timestamp: 4ee9bec2

Fault Module Name: StackHash_0a9e

Fault Module Version: 0.0.0.0

Fault Module Timestamp: 00000000

Exception Offset: fffde000

Exception Code: c0000005

Exception Data: 00000008

OS Version: 6.1.7601.2.1.0.768.3

Locale ID: 1033

Additional Information 1: 0a9e

Additional Information 2: 0a9e372d3b4ad19135b953a78882e789

Additional Information 3: 0a9e

Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

Share this post


Link to post

OK, found my old Civ 4 vanilla, and erased the old (wouldn't delete, so I just renamed the folder) and installed again. In the install I got error messages saying "this game has known compatibility issues with this version of windows". Hoping that once I toss on BTS and upload that patch, it will fix things to be OK.

Share this post


Link to post

Downloading 3.19 now, so far so good.

 

If anybody has any ideas on 5 past the uninstall and redo option....

Share this post


Link to post

post in the other sub forum??

Share this post


Link to post

See, I just went and purchased Civ4 complete for myself on steam and gave my father my old disks from Civ4 vanilla and warlords.

Share this post


Link to post
If anybody has any ideas on 5 past the uninstall and redo option....

 

What about the 'check for integrity' option in Steam? You have have a corrupt file and that should/could fix it?

Share this post


Link to post

Hmmm, haven't seen that option, will look for it.

Share this post


Link to post

I'm home now, so:

 

Right click game in your library, select 'properties', select the 'local files' tab, select 'verify integrity of game cache' button.

 

Might work.....

Share this post


Link to post

I'm guessing you run Win7. Civ4 will only then only work if you apply the latest patch. Otherwise it will screw up your graphics (as in, won't display properly, it will not burn your GPU ;))

Share this post


Link to post

Well, it kinda works.

 

A lot of the buttons have the file stings instead of the button name, and I cannot change civics except when I first unlock it, else it seams like it works.

Unfortunately the Civics bug means that I cannot really play it except single player to just refresh myself.

Share this post


Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  
Followers 0