Wodong

DirectDraw=0 failing me!

13 posts in this topic

I just got a new Asus laptop K53SD. After a LOT of fiddling, I managed to get SMACX installed and (mostly) functional. Buuut, adding DirectDraw=0 into the Alpha.ini (it's in the correct place, before [Preferences]) causes it to consistently, 100% of the time crash to desktop.

 

This is the situation:

*Running Windows 7 64 bit, OS is a clean install on Asus Laptop.

*Maximum (also "optimal") resolution is 1366x768, Intel HD/NVidia Geforce 610M for graphics.

*Fully patched and XP compatibility patch installed.

*SMAX is installed directly into E: drive, not in the program files or (x86) program files directories.

 

Just to reiterate, SMACX functions if I DON'T use DirectDraw=0, but then of course I have a really screwed up aspect ratio because of the screen on my laptop. Kind of kills the enjoyment of the game, and I don't have another computer around here that I can use. Any similar experiences of this? Any workarounds?

Share this post


Link to post

I can't help you, but I'd be surprise if you didn't find someone who can.

 

ADM: Maybe this should be moved to the "Help, bugs and tips" forum?

Share this post


Link to post

The directdraw command forces the game to run in your native Windows screen resolution, but SMAX won't run at 1366x768. You should delete the directdraw line and change your iini file to look like

 

[Alpha Centauri]

video mode=1024

 

That should force the game to run at 1024x768, which is the best you can do.

 

HTH

 

Petek

Share this post


Link to post

That's interesting Petek, what's wrong with 1366x768 in particular? I run it at 1680 x 1050.

 

As I mentioned in the identical thread Wodong started on CGN, he should be able to prevent aspect ratio distortion using the "maintain aspect ratio" scaling option in his nividia graphics options.

Share this post


Link to post

Nothing is specifically wrong with 1366x768, but I've seen other laptops running odd aspect ratios that had similar problems. Forcing 1024X768 allowed the game to run. I didn't know about the nVidia settings. Do you have to do that on your system, or does DirectDraw=0 work with no other tweaking?

 

@Wodong -- Definitely try chuft's suggestion first.

Share this post


Link to post

The nividia (and ati) graphics scaling settings are for people playing it in a normal 4:3 aspect ratio, such as 1024 x 768. It keeps it from being stretched out to fit the whole screen ,which is normally widescreen nowadays. These settings are used for for any game, not just smac. For example Fallout, or Baldur's Gate, etc run in a 4:3 resolution. You need to use the scaling setting "maintain aspect ratio" to play them without distortion.

 

You don't need scaling settings if you are using directdraw=0 since the game is not being scaled (played at 4:3 but blown up toll fill the screen by stretching the image sideways), it is being played at the native desktop resolution with no aspect ratio distortion.

Share this post


Link to post

Sometimes a picture (or four) is worth a thousand words.

 

Note WPC is still :mad: resizing images so you have to right click on these and View Image (in Firefox, in another browser you're on your own) to see them at full resolution.

 

 

This is what Wodong is talking about: playing at 1024 x 768 stretched to fill a widescreen monitor vertically and horizontally, with distortion from failing to maintain a 4:3 aspect ratio:

 

ratio1.gif

 

 

 

 

This is the playing with Maintain Aspect Ratio enabled for scaling, playing at 1024 x 768, stretched vertically to fill the screen and horizontally in the 4:3 ratio to maintain the proper aspect ratio. This leaves a gap to the left and right which are filled in with black bars.

 

ratio2.gif

 

 

 

 

This is playing with directdraw=0 on a widescreen monitor. No stretching or distortion or scaling, just playing in 1680 x 1050 resolution. Things naturally look smaller at this higher res.

 

 

ratio3.gif

 

 

 

 

Here is where the scaling option and maintain aspect ratio is found in an ATI catalyst control panel. Nividia has an identical feature (my previous cards were nividia cards):

 

 

ratio4.gif

Share this post


Link to post

Since we're on this subject I should mention that if using directdraw=0, do NOT alt-tab out of the game once a Special Project movie has played. Bad things will start happening. The movie player is a different app than smac itself and problems occur if you tab out anytime after a movie has played in the current session. Your game will eventually crash if you try to play on after tabbing out and back in after a movie has played. The answer is to always save after watching a movie (typically once you've reached the end of the production cycle), quit, then run the game again and load the save.

 

This problem does not occur if you are not using the directdraw=0 option.

Share this post


Link to post

Didn't know that alt-tabbing after a movie would do that. Then again, I turn off the movies because once you've seen them a hundred times they kind of lose their charm.

 

Chuft, your pictures tell the story I wanted to tell. Except, for me, there's no second picture. My nVidia control panel is bonkers, even with a clean install. I blame either Asus or nVidia, or maybe both. I certainly blame Asus for the damn 1366x768 screen resolution. Sadly I don't have an option for aspect ratio. I've tried reinstalling the nVidia graphics drivers clean install, based on the other pics I've seen online of their control panel I still have a gimped version of it. Also, for some reason I have an Intel HD graphics processor "in addition" to the nVidia. Which I find highly suspicious, but it appears that I have at least the dedicated RAM of the 610M running. Attempting to turn off/disable the Intel in any way causes the display to go black until I hard power off then reboot the computer.

 

PeteK, I wish it wasn't so, but you're so far completely right about the oddball resolution. I can play at a more normal resolution, but this frikkin laptop forces the display to fill the screen, so I end up with sometime like Chuft's first image, but worse because the screen's native resolution is 1.77 something (683:384?) instead of 16:9 4:3 or even 16:10. This thing actually makes me kind of miss the 256MB RAM integrated graphics card wonder that I had been using until the motherboard started going out, thereby precipitating the purchase of this thing. The stretching/distortion from running video mode=1024 makes the game completely unenjoyable though.

 

Thank you everyone so far for the advice, I'll keep looking and always open to more ideas.

Share this post


Link to post

As I no longer am using an nividia machine, I can't look at its control panel, but I do recall that the scaling/aspect ratio thing was fairly hidden the first time I tried to look for it. It did not show up until I enabled something else that looked like it had to do with HDTVs, something like "custom timings". From a few casual searches it seems scaling has been an issue with Windows 7 machines for both nvidia and ati, with new drivers supposedly fixing the problem late last year. I would do a search for your laptop model and "scaling" to see if you can find specific advice or workarounds for making the nividia drivers work on your machine properly (or access hidden settings - I think on some machines it only appears if you drop desktop resolution to 800 x 600, at which point you can enable scaling, then re-up the resolution).

 

Also, for some reason I have an Intel HD graphics processor "in addition" to the nVidia.

 

I believe modern laptops are doing this for power saving purposes, i.e. only using the 3D card when required to (such as by games) and using the lower energy Intel chipset for word processing and other undemanding tasks. My friend just got a new MacBook Pro and it too has both ati and intel graphics built into it, and it switches between them on the fly as needed.

 

Another option is to play smac in a window, using a third party free software like d3dwindower. I think I successfully played smac using this program in the past. It would just run inside a normal 1024 x 768 window

Share this post


Link to post

Chuft, took your advice, dropped the Intel to 800 res then enabled scaling, then bumped it back to the default resolution. I've got the black bars on the side, running 1024 instead of DirectDraw. At least it looks normal, and I'll learn to ignore the black bars easily enough. So far SMACX seems stable, and hope it stays that way. Now I just have to remember to NEVER fiddle with the display setting again and I should be fine.

 

Looked into D3Dwindower. Couldn't open the youtube link, being in China and all. But did find a download. That particular program v.1.88 didn't do squat for me, but I think i'll content myself with being able to play again.

 

Still casting a dirty eye on the whole Intel/nVidia thing. Some things just ain't right in my book. Now, off to more playtesting to make sure SMACX behaves itself.

Share this post


Link to post

Hope everything works for you. Due to the zooming in and out with the z and x keys, I find normal resolution works fine for me. I mostly play hi res just for making screenshots. Personally I'd rather have black bars than distortion - maybe because I got used to them on my HDTV, where I often have to do the same thing (watch 4:3 TV shows with black bars rather than see everyone have squashed fat heads).

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now