plugz

TCP/IP Problem

6 posts in this topic

:mad::mad::mad:

I use Hamachi 2.0.1 to play SMAX

When I join game. It goes back to the menu.

When I create. People who join me have the same problem as me.

 

So I tried the solution in the pinned post.

Uninstall the Hamachi 2 and install Hamachi 1.0.3.0

And config the network adapter as same as the solution.

Same problem.

 

I've forwarded port for directplay already. ( 2300-2400 and 47624 tcp/udp including 15000 for game port)

I tried to config firewall and disable it. No working either.

 

So I goes to gameranger. and you know what?

When create It doesn't have TCP/IP directplay in the game.

It's just showed me IPX and Hotseat mode.

 

Who can help me about this situation? :huh:

I can play almost every games with hamachi and gameranger but not this game.

Edited by plugz

Share this post


Link to post

hello and wlcome to WePlayCiv!

what OS are you using? also what version of SMAX? is everybody on the same version?

 

So I goes to gameranger. and you know what?

When create It doesn't have TCP/IP directplay in the game.

It's just showed me IPX and Hotseat mode.

when i connect in GameRanger i have 2 options: Game Ranger and Hot seat/Play-by-email. i haven't seen IPX on that menu recently.

Share this post


Link to post

Yes, they have the same version as me.

I use Windows 7 64 bit.

Share this post


Link to post
I use Windows 7 64 bit.

you can't play SMAX on GameRanger with Win7. the last update there was ment only for XP users, but i'm not sure it is playable even for that.

i always get a DirectX error when trying to connect.

 

for Hamachi i guess you followed Draz's guide here: http://www.weplayciv.com/forums/showthread.php?1873-From-installation-to-tcp-ip-games-SMAC(X)-Hamachi-and-you.

if you did that and still doesn't work i suggest by-passing your router (if that's possible). i do that when when i bounce back from the game with relative success most of the times.

 

Yes, they have the same version as me.

what's that: SMAX 2.0 / 2.0+XP patch / 2.0+XP patch+unofficial ?

Share this post


Link to post

2.0 + xp patch.

Not include the Unoffcial patch.

 

Does it matter?

Share this post


Link to post

seems so. i remember downgrading from unofficial to 2.0+XP patch helped me once to connect in a Hamachi game, but i can't guarantee everybody was genuine about playing with scient's patch, so... :dunno:

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now