Riidi

TCP-IP problems (not hamachi)

3 posts in this topic

Recently me and a few friends have started playing SMAX over tcp/ip. We all followed the exact same install procedure using the same version of the game, the official patch, and scient's unofficial patch. We're all running windows 7 64-bit. And yet I am the only one having the following two (possibly related) problems:

 

The first problem is that I have become simply unable to connect to a server. I've had this problem twice, and I don't know how I fixed it the first time, but I think it came un-fixed when I reset my router. Basically, if I don't forward ports 2300-2400 through to my computer, I can't locate any games and nobody can connect to the ones I host. But if I do forward ports 2300-2400 to my computer, the game hangs when I select "Host game" or when I type in the IP to join. I'm using ESET's Nod32 antivirus, but I disabled it and I still have the problem. I'm behind a Belkin router.

 

The second problem is a bit weirder: when I join a game and the host loads a saved game we previously played on, everyone else in the game sees the players as their chosen factions. But I see the Peacekeepers player as the Blue lal of the Hive:Peacekeepers, and the pirates player as the dark green Svensgaard of the Consciousness:Pirates. Furthermore, if I select my own faction when the game loads I get a totally black worldmap, as if I have become a ghost faction. If I try all the other factions I can usually find one that will say "Spartans:Drones" and let me load successfully as the drones. Once I do load, the graphical theme is all messed up, like I become Domai of the Drones but all my bases look like the Spartans and my portrait is Santiago's. I'm the only one who experiences these glitches.

 

What is going on, here?!

Share this post


Link to post

Sounds like the faction colors are an "Alpha Centauri.ini" problem. It occurs in multiplayer and scenarios I believe. You can either do 1 of 2 things to fix it. Manually enter in the factions in the correct order in the "alpha centauri.ini" file, on the lines that say Faction 1= Faction 2= etc., or you can start a single player game with the factions that are in your multiplayer game, they also need to be in the same order as they are in the multiplayer game. Play one or two turns and it will change the .ini file automatically.

 

As for the problems on tcp/ip I had similar problems when I tried to play a while back. This may or may not help since you are not using the same programs, OS, and hardware I am, but it might be worth a try. I had to turn off widows firewall and create an exception for terran.exe and terranx.exe in my anti-virus programs firewall. After doing these two things I was able to play IP without problems.

Share this post


Link to post
Sounds like the faction colors are an "Alpha Centauri.ini" problem. It occurs in multiplayer and scenarios I believe. You can either do 1 of 2 things to fix it. Manually enter in the factions in the correct order in the "alpha centauri.ini" file, on the lines that say Faction 1= Faction 2= etc., or you can start a single player game with the factions that are in your multiplayer game, they also need to be in the same order as they are in the multiplayer game. Play one or two turns and it will change the .ini file automatically.

 

As for the problems on tcp/ip I had similar problems when I tried to play a while back. This may or may not help since you are not using the same programs, OS, and hardware I am, but it might be worth a try. I had to turn off widows firewall and create an exception for terran.exe and terranx.exe in my anti-virus programs firewall. After doing these two things I was able to play IP without problems.

 

Thanks for the tip on the alpha centauri.ini, as far as the tcp/ip problems I have tried turning off windows firewall and even tried turning off the AV but it still is acting weirdly. I just wish I could trace down what fixed it the first time :mad:

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now