Orbinou

alpha centauri, windows 7, please help ^^

73 posts in this topic

Okay, it's running. Petek, you stride the Earth like the giant among men you are.

 

...

 

 

Now, any idea how to get rid of this popping up every time I launch the game without turning off the feature entirely?

 

attachment.php?attachmentid=10923&d=1320965651

UserAccountControl.jpg

Share this post


Link to post

Well, I have gained some weight recently. Surprised you noticed!

 

I get the same dialog when starting the game. It's due to running SMAX as administrator. SMAX has problems in Windows 7 (such as saving game files) when not running as admin, so I just live with it. If you want to bypass the message, search for disable uac for specific programs windows 7. It can be done, but it involves modifying the OS more than I was willing to do.

Share this post


Link to post

Me too. Turning when the notifications appear all the way down seemed too risky.

 

I've gained about 30 pounds since June, myself, I assume because the medication for my diabetes gave me my appetite back. My weight had gotten as low as it's been since my show business days. Not dying crippled is better, but dang, I looked good. Pity.

Share this post


Link to post

I'm also having alot of trouble getting SMAC/X to work on my windows 7 laptop. I have followed all the steps (installed in order the necessary patches) but it has not seemed to work. When I start terranx.exe the game begins to load.... but then quickly just exits back to the desktop. The same happens when I select terran.exe, but when I select axstart.exe I get an actual error message "c:\games\alphacentauri". All I can do is click OK, then forced back to desktop. I've tried all the steps on this page and experimented with all the compatibility settings I could... and nothing. I've read that it's possible to run SMAC/X on windows 7, so I'm optimistic, but I have been having a hell of a time. I really hope I can get this working, I'd like to play against some actual humans! Thanks if anyone can help...

Share this post


Link to post

So you did try this?

OK, your Alpha Centauri.ini file should have the line

 

ForceOldVoxelAlgorithm=0

 

If so, change the 0 to a 1. If the line isn't present, add it (with a 1) to the [PREFERENCES] section of the ini file. That should do it.

You can edit Alpha Centauri.ini with Notepad, though I had to delete the file to get Notepad to save it. Be careful not to let it save it with the default extension, .txt, but the original, .ini.

 

If that doesn't work, I'm outta notions, but Petek could check by any time. He most never fails.

 

 

 

We're always happy to take in another MPer. I'm sure you've spotted the subforum for that. Read around, especially the stickied stuff at the top of the page and learn the current proceedure for getting yourself a game, and I'm sure the guys will take care of you.

 

Don't be afraid to post about anything, questions, opinions, or otherwise, in the appropriate folder. Good hunting, sir.

Share this post


Link to post

No, I haven't tried that... this is probably going to sound silly, but I searched my Alphacentauri folder and cannot seem to find any "Alpha Centauri.ini" file.... I searched by file name and file type and nothing. Sorry for the silly question, but I really have a good feeling this is going to work once I figure it out! :D

Share this post


Link to post
I'm also having alot of trouble getting SMAC/X to work on my windows 7 laptop. I have followed all the steps (installed in order the necessary patches) but it has not seemed to work. When I start terranx.exe the game begins to load.... but then quickly just exits back to the desktop. The same happens when I select terran.exe, but when I select axstart.exe I get an actual error message "c:\games\alphacentauri". All I can do is click OK, then forced back to desktop. I've tried all the steps on this page and experimented with all the compatibility settings I could... and nothing. I've read that it's possible to run SMAC/X on windows 7, so I'm optimistic, but I have been having a hell of a time. I really hope I can get this working, I'd like to play against some actual humans! Thanks if anyone can help...

 

Howdy tyrant and welcome to WPC!

 

First thing I'd suggest you to try is create a shortcut (if you don't already have one) to either terran.exe or terranx.exe (doesn't matter which). Right-click on the shortcut, go to Properties and select the Compatibility tab. Play around with various settings, starting with running the program in Window XP SP3 mode. Please post again if none of those options help. If you do so, please let us know at what screen resolution your laptop runs. HTH

 

Petek

 

ETA: @tyrant --- You won't have an Alpha Centauri.ini file until after you successfully start the game.

Share this post


Link to post

It's in the root AC directory. I had a little trouble finding it , too; try View>details and Sort By>Type in the folder, and watch the right column that tells what type - the type/file extentions are listed alphabetically.

 

Ah. Ninja'd by Petek. Listen to him.

 

 

Do we have an .ini file posted anywhere for someone in his situation?

Share this post


Link to post

(snipped)

 

Do we have an .ini file posted anywhere for someone in his situation?

 

Good idea, but I don't think we need one. The lack of an .ini file isn't causing the current problem. A generic one will be created once the game starts. If anyone who already has an .ini file needs to create a generic one (say, for troubleshooting), all they have to do is rename their current .ini and start a new game.

Share this post


Link to post

[shrugs] He said he'd already tried the compatibility settings. Should he try the scientIfficPatch? 'Cause the .ini trick won't work without an .ini to alter and he needs to run the game to generate one....

Share this post


Link to post

But unfortunately it's still not working... I'm beginning to lose morale. I have a shortcut of terranx.exe on the desktop, and have tried all the comparability settings, changed my screen resolution, and fiddled with other settings, but no dice. I don't know what else there is to do, I'm willing to try downloading a working version of the ".ini" file and see if that works, but other than that i'm out of ideas.... :S

Share this post


Link to post
[shrugs] He said he'd already tried the compatibility settings. Should he try the scientIfficPatch? 'Cause the .ini trick won't work without an .ini to alter and he needs to run the game to generate one....

 

Oh' date=' you're right. I overlooked that he'd already tried compatibility settings. I was assuming that he had installed the unofficial patch ("installed in order the necessary patches"), but perhaps not.

 

@tyrant -- Did you install the unofficial patch? If not, please do so. If the games still don't start, then try starting Windows in safe mode and try again. Also, please let us know what is your Windows video resolution. Thanks.

Share this post


Link to post

I did install the unofficial patch. I just restarted in safe mode but got the exact same results. I then restarted in "allow low video resolution" mode and got the same thing. .. My default screen resolution was 1600 x 900, I then tried 800 x 600, 1280 by 720, and numerous other resolutions, but all with the same result. I'm going to just try re-installing everything and see what happens. If that doesn't work then I'm pretty much out of ideas. Maybe I can download the correct .ini file? Anyways, I'll update you guys after the re-install.

Share this post


Link to post

Huh.

 

It's not a recognized file type for uploading, so here's what to try- upload the attached .txt file. It's the .ini with the suffix changed. Click on it and it'll open in Notepad. Save As it to your AC root folder with the .ini suffix instead of the .txt I had to upload it with. If the .ini dodge is what your machine needs, that should do it.

 

Let us know if this works.

Alpha Centauri.txt

Share this post


Link to post

...I feel safe in assuming this radio silence means tyrant is busy playing AC now...

Share this post


Link to post

ok so ive seen that some people have had the same problem and ive solved it for for the reg SMAC but on SMACX i still get it.

 

how i solved it at first was instead of installing and running autorun, i just took the "program" files

from the cd and put it in a "new folder" on my desktop and SMAC ran fine. Only after i changed the

compatibility settings (i have windows7) for "terran.exe"

 

so afterwards, i put the "program" files for SMACX in and this is what happens:

SMACX starts

gets to the main screen

pick the map

the difficulty

but when i pick the rules it crashes out and says that "terranx.exe has stopped working"

this only happens for SMACX, the og game still runs tho

Share this post


Link to post

Welcome to WPC and the Alpha Centauri forum!

 

Can you start a game of SMAX by using the Quick Start option? If so, you've run into a problem that has been solved in the past simply by uninstalling and reinstalling both games. Follow the instructions in this thread for the correct order of installing the games and various patches. Ignore the stuff about Hamachi, which is for multiplayer.

 

If this doesn't help, or if you have any questions, please post again. If you do so, please mention what, if any, other troubleshooting steps you've tried and which version of the games you have (for example, original release, Planetary Pack, Sold-Out re-release, etc.).

 

HTH

 

Petek

Edited by Petek
Welcome to correct forum!

Share this post


Link to post

EDIT: ninja'd by the Master. Listen to him, not me.

 

 

Hmmm. This is maybe way over my tech support paygrade if you've already tried the compatability settings accessable from the desktop shortcut. You should launch terran.exe and terranx.exe with shortcuts so you can use those and not have to scroll through the folder.

 

The only other thing I know of is that your problem sounds a little like there are corrupted or missing files; you might try a reinstall.

 

If that doesn't work, Petek should swing by sometime today and take care of you. Let us know if my suggestions help, and be sure to relate any error messages precisely, as those help Petek diagnose.

 

 

 

CFC, Petek?

Share this post


Link to post

 

 

CFC' date=' Petek?[/quote']

 

Are you commenting that the same problem came up at CFC? Yep, also at 'poly. I found a reference as early as 2001.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now